RDP Session mit PHP erzeugen

Wie kann aus einer Website heraus eine RDP Session gestartet werden?

$file = 'screen mode id:i:2
desktopwidth:i:1436
desktopheight:i:925
session bpp:i:16
auto connect:i:1
full address:s:192.168.120.10
compression:i:1
keyboardhook:i:2
audiomode:i:2
redirectdrives:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:0
displayconnectionbar:i:1
alternate shell:s:
shell working directory:s:
disable wallpaper:i:1
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:1
bitmapcachepersistenable:i:1
winposstr:s:0,3,0,0,800,600
redirectclipboard:i:1
redirectposdevices:i:0
drivestoredirect:s:
autoreconnection enabled:i:1
authentication level:i:0
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
allow desktop composition:i:0
allow font smoothing:i:0
disable cursor setting:i:0
gatewayhostname:s:
gatewayusagemethod:i:0
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0';

header("Content-Disposition: attachment; filename=dateiname.rdp");
header("Content-Type: application/rdp");
print $file;
exit();

Menü’s verschoben

Hier beschreibe ich einen “Bug”, der einen richtig zum Narren halten kann. Zumindest hat er das mit mir getan: Die Hauptmenü’s von Programmen sind plötzlich (fast) alle nach links verschoben.

Seit längerer Zeit arbeite ich an einer kleinen Software mit grafischer Oberfläche, die ich mit dem Embarcadero C++ Builder XE2 entwickle. Ich wollte, dass die GUI richtig toll aussieht, und habe mich daher für de Verwendung von TMS Components entschieden.

Da ich an diesem Projekt meist zu Hause arbeite, mache ich sehr viel an meinem privaten Windows7-Notebook. Alles war sehr toll, bis mir eines Tages eine Unschönheit in der GUI auffiel: Das Hauptmenü war irgendwie verschoben:

R[el]Ational_2015-04-13_10-18-28-

Das Menü zeigte plötzlich nach links, anstelle dass es wie gewohnt symmetrisch nach unten ausgerichtet war.

Auf meinem Zweitcomputer hatte ich ebenfalls eine Entwicklungsumgebung eingerichtet und dort war alles so, wie ich es erwarten würde:

R[el]Ational_2015-04-13_10-18-28

Nach etlichen Untersuchungen und Vergleichen glaubte ich die Ursache gefunden zu haben: Es mussen die TMS Components sein, da ich von diesen 2 unterschiedliche Versionen im Einsatz hatte. Da diese eh schon etliche Semester auf dem Buckel hatten entschied ich mich kurzerhand zu einem Upgrade und installierte die neueste Version auf meinem Notebook.

Eine Stunde und runde 250€ später war das Ergebnis ernüchternd: alles war beim alten. Und erst jetzt fiel mir auf, dass auch andere Programme von diesem Problem betroffen waren. So z.B. Notepad, das vermutlich nicht auf TMS Components zurück greift:

Unbenannt - Editor_2015-04-13_10-01-30

Nach einiger Recherche fand ich heraus, dass es sich um ein Problem von Windows 7 handelt und dass dieses Problem häufig in Zusammenhang mit einem Upgrade auf SP1 stehen könnte: Es seien die Tablet PC Einstellungen, die auf “Linkshand” eingerichtet werden müssen:

Tablet PC-Einstellungen_2015-04-13_10-22-15

Der Dialog sei in der Systemsteuerung hinterlegt. Bei mir war das allerdings nicht so, ich musste den Dialog mit folgendem Befehl aufrufen:

Start / Ausführen und:

shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}

Option Linkshändig aktivieren hat dann das Problem behoben

 

Kind-Klasse von TDataModule oder TForm und Stack Overflow

In C++ Builder Programmen kann es bei der Vererbung von TDataModule oder TForm Klassen zu einer bösen Überraschung in Form eines Stapelüberlaufs kommen:

class TInvoices : public TDataModule
{
    __published:

    private:
        int FCustomerId;
    public:
        // standard constructor
        __fastcall TInvoices( TComponent* Owner );
        // überladener constructor mit zusätzlichem parameter
        __fastcall TInvoices( TComponent* Owner, int ACustomerId );

        __property int CustomerId = { read=FCustomerId, write=FCustomerId };
};

Grund für den Stack Overflow ist der 2. Parameter (“int ACustomerId”) im überladenen constructor, der nachträglich eingefügt wurde.

Mögliche Lösungen des Problems:

  • Hinter dem 2. Parameter weitere Parameter anfügen
  • Die beiden Parameter vertauschen (int/TComponet)
  • Den Datentyp des 2. Parameter ändern (z.B. unsigned long anstelle von int)

UPDATE mit JOIN unter MSSQL

Eine Sache, die im SQL-“Standard” überall ein wenig anders ist, ist das UPDATE unter Einbezug einer zweiten Tabelle:

UPDATE T1
SET T1.articleNumber = T2.articleId
FROM TableOne T1
JOIN TableTwo T2 ON T2.id = T1.id