Menü’s verschoben

Hier beschreibe ich einen “Bug”, der einen richtig zum Narren halten kann. Zumindest hat er das mit mir getan: Die Hauptmenü’s von Programmen sind plötzlich (fast) alle nach links verschoben.

Seit längerer Zeit arbeite ich an einer kleinen Software mit grafischer Oberfläche, die ich mit dem Embarcadero C++ Builder XE2 entwickle. Ich wollte, dass die GUI richtig toll aussieht, und habe mich daher für de Verwendung von TMS Components entschieden.

Da ich an diesem Projekt meist zu Hause arbeite, mache ich sehr viel an meinem privaten Windows7-Notebook. Alles war sehr toll, bis mir eines Tages eine Unschönheit in der GUI auffiel: Das Hauptmenü war irgendwie verschoben:

R[el]Ational_2015-04-13_10-18-28-

Das Menü zeigte plötzlich nach links, anstelle dass es wie gewohnt symmetrisch nach unten ausgerichtet war.

Auf meinem Zweitcomputer hatte ich ebenfalls eine Entwicklungsumgebung eingerichtet und dort war alles so, wie ich es erwarten würde:

R[el]Ational_2015-04-13_10-18-28

Nach etlichen Untersuchungen und Vergleichen glaubte ich die Ursache gefunden zu haben: Es mussen die TMS Components sein, da ich von diesen 2 unterschiedliche Versionen im Einsatz hatte. Da diese eh schon etliche Semester auf dem Buckel hatten entschied ich mich kurzerhand zu einem Upgrade und installierte die neueste Version auf meinem Notebook.

Eine Stunde und runde 250€ später war das Ergebnis ernüchternd: alles war beim alten. Und erst jetzt fiel mir auf, dass auch andere Programme von diesem Problem betroffen waren. So z.B. Notepad, das vermutlich nicht auf TMS Components zurück greift:

Unbenannt - Editor_2015-04-13_10-01-30

Nach einiger Recherche fand ich heraus, dass es sich um ein Problem von Windows 7 handelt und dass dieses Problem häufig in Zusammenhang mit einem Upgrade auf SP1 stehen könnte: Es seien die Tablet PC Einstellungen, die auf “Linkshand” eingerichtet werden müssen:

Tablet PC-Einstellungen_2015-04-13_10-22-15

Der Dialog sei in der Systemsteuerung hinterlegt. Bei mir war das allerdings nicht so, ich musste den Dialog mit folgendem Befehl aufrufen:

Start / Ausführen und:

shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}

Option Linkshändig aktivieren hat dann das Problem behoben

 

Facebooktwittergoogle_pluspinterestlinkedin

Leave a Reply

Your email address will not be published. Required fields are marked *